hdu 2001 计算两点间的距离
ACM比赛整理
共 635字,需浏览 2分钟
·
2023-01-12 17:37
计算两点间的距离
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 395053 Accepted Submission(s): 133339
Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
Output
对于每组输入数据,输出一行,结果保留两位小数。
Sample Input
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41
代码:
#include<stdio.h>
#include<math.h>
int main()
{
double x1,y1,x2,y2,s;
while(scanf("%lf %lf %lf %lf",&x1,&y1,&x2,&y2) != EOF)
{
s=sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1));
printf("%.2lf\n",s);
}
return 0;
}
评论