hdu 2056 Rectangles

ACM比赛整理

共 1774字,需浏览 4分钟

 ·

2021-07-17 12:12

Rectangles

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41029    Accepted Submission(s): 13633


Problem Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

 


Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

 


Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

 


Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

 


Sample Output

1.00
56.25



代码:

#include "stdio.h"
#include "stdlib.h"
#include "math.h"
int cmp(const void *a,const void *b)
{
return *(double *)a>*(double *)b?1:-1;
}
int main()
{
int n=1,i;
double s,l,h,x[4],y[4],x1,x2,x3,x4,y1,y2,y3,y4;
while(~scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4))
{
x[0]=x1;x[1]=x2;x[2]=x3;x[3]=x4;
y[0]=y1;y[1]=y2;y[2]=y3;y[3]=y4;
qsort(x,4,sizeof(x[0]),cmp);
qsort(y,4,sizeof(y[0]),cmp);
l=fabs(x2-x1)+fabs(x4-x3)-(x[3]-x[0]);
h=fabs(y2-y1)+fabs(y4-y3)-(y[3]-y[0]);
s=l*h;
if(l<=0 || h<=0) s=0.00;
printf("%.2lf\n",s);
}
return 0;
}


浏览 10
点赞
评论
收藏
分享

手机扫一扫分享

举报
评论
图片
表情
推荐
点赞
评论
收藏
分享

手机扫一扫分享

举报