hdu 2058 The sum problem

ACM比赛整理

共 1270字,需浏览 3分钟

 ·

2021-07-17 12:11

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 43443    Accepted Submission(s): 13238


Problem Description

Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

 


Input

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

 


Output

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

 


Sample Input

20 10
50 30
0 0

 


Sample Output

[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]



代码:

#include<stdio.h>
#include<math.h>
int n,m;
int main()
{
while(~scanf("%d%d", &n, &m))
{
if( n == 0 && m == 0)
break;
for(int i = sqrt(2 * m); i >= 1; i --)
{
int a = (m - ((i - 1) * i) / 2) / i;
if(m == a * i + (i * (i - 1)) / 2)
printf("[%d,%d]\n",a,a+i-1);
}
printf("\n");
}
return 0;
}



浏览 7
点赞
评论
收藏
分享

手机扫一扫分享

举报
评论
图片
表情
推荐
点赞
评论
收藏
分享

手机扫一扫分享

举报